fbt12
Posts: 37
Joined: Mon Oct 28, 2019 11:34 am

intermittent (soft) knock & intermittent (one time so far) labored steering

Tue Aug 04, 2020 4:21 pm

Got 2 problems. Plan on bringing it into BMW SF (still have about 12 months left on original warranty). Before i do, i am looking to this community for a bit more insight before bringing it in.

Problem 1:

Purchased October 31, 2019. Soft knocking sound seems to occur during hard acceleration during a left hand turn. It occurred about once every few weeks. It stopped for a couple of months after i installed new springs & wheel spacers. Just came back. My dashcam is able to record interior sound. When i hear the sound while driving, it is a soft knock... a muffled knock that sounds like it is coming from below the passenger side door. Prior to the spring/spacer install, i would (remember) a knock-knock. The recent event was a single knock. I captured the video (with audio) from the dashcam. However, when i listen to the sound on my computer, the knock is much louder than i remember. I am guessing that the dashcam that is securely mounted on the passenger side of the windshield is receiving both audible sound and the direct vibration through the car body/frame/suspension.

Saw this post ---> https://mybmwi3.com/forum/viewtopic.php?f=11&t=4711
Did not seem to fit because my noises are intermittent and i am not able to reproduce my sound on demand (e.g. accelerating in a curve; or flooring it on a freeway on ramp).


Problem 2:

On Monday, i took off at 10am for some errands. Temperatures were in the upper 50's. I noticed that turning was more labored for me. It was stiffer and heavy....as if no power assist. There was no self-steering or pulling whether i was on the freeway (60-65) or on the streets (20-40mph). After a 20 minute drive i parked for an hour. When i returned....no issues.


Will be scheduling visit for the next week.

Any thoughts of what i can look for or suggest the mechanic look for?

richs
Posts: 59
Joined: Sat Apr 04, 2020 5:09 am

Re: intermittent (soft) knock & intermittent (one time so far) labored steering

Tue Aug 04, 2020 5:45 pm

I have no idea about your knock issue, so I won't cluelessly speculate about it.

As for your other problem, I also experienced the heavy steering effort issue, exactly once in the four months I've owned my 2017 i3. It happened right after I started the car one time. After parking, shutting down, and restarting, the steering was normal again. Software bug?

JohnWasser
Posts: 68
Joined: Sat Mar 07, 2020 6:15 pm

Re: intermittent (soft) knock & intermittent (one time so far) labored steering

Wed Aug 05, 2020 6:37 pm

The power steering cutting out randomly, usually at startup, is a symptom of a communication failure with the power steering module. The late-2019 (December?) "Integration Level" (software version package) is supposed to fix it. Tell the dealer about the power steering sometimes not working and they should update all the modules to the latest software version ("Integration Level")

frictioncircle
Posts: 115
Joined: Fri Nov 25, 2016 11:23 pm
Location: USA West Coast

Re: intermittent (soft) knock & intermittent (one time so far) labored steering

Fri Aug 07, 2020 1:14 am

fbt12 –

Please share the results of your service visit.

Knowing the cause of the intermittent knocking issue would be particularly interesting.

Good luck with the dealer!

fbt12
Posts: 37
Joined: Mon Oct 28, 2019 11:34 am

Re: intermittent (soft) knock & intermittent (one time so far) labored steering

Sat Aug 15, 2020 9:46 pm

Update: bringing the car in on Wed.Aug 19th.

I will update this thread with results.

Wish me luck.

fbt12
Posts: 37
Joined: Mon Oct 28, 2019 11:34 am

Re: intermittent (soft) knock & intermittent (one time so far) labored steering

Fri Aug 21, 2020 12:13 pm

Got it back from BMW SF.

Soft knocking --- It turns out that it was not the car. I am clearly not the brightest bulb on this forum. The noise was coming from my Thinkware U1000 dash cam. When the noise first appeared more often (about June 2020), i called the supplier to get some feedback on the dashcam alerts -- they confirmed that the dash cam only has a beep sound and actual (recorded) spoken announcements for alerts.

The SF BMW called me when they had the car. They heard the sound alright. And when they (with my permission) unplugged the dash cam (power, radar module & rear camera), the sound went away. After chatting with Thinkware support (25 minute wait), they sent me a link for alert sounds. Yup....the LDWS (lane departure warning signal) was the origin. The sensitivity on mine was set at LOW which resulted in less notices to me.

Lesson: I need to spend more time tuning my dash cam settings. Not sure why the alerts increased over time. Has my driving changed that much??? It has a ton of features and i had a separate battery installed (under rear seat) to provide extended coverage when using long term parking for multiple days.

Tip my hat to the service advisor @ SF BMW. He patiently listened to this old man even when he was fully convinced the dash cam was the source. He listened to all my video files and road in the car quite a bit to isolate my knocking. Even when he was pretty convinced it was the dash cam he humored me and took it out once more for a longer drive with & without the dash cam connected.

-----------------------------------------------------------------------------------

Okay...steering heaviness. There was a bulletin from BMW. As pointed out in other postings, BMW does not automatically install software upgrades. They were not able to confirm a steering problem but since i complained, they upgraded.

On the work order i believe this is the relevant text:
36824 EPS SOFTWARE ERROR. Not able to verify the concern at this visit. Connected battery charger (assume main HV battery but did not ask). Performed short test. No related faults stored. There is applicable SIB 32 02 14. Program the vehicle. Road test vehicle.
Guess time will tell if the problem comes back.... or not.

I previously coded my car in November 2019. I have a 2017 REx --- standard stuff --- AM radio, default driving Ecco Pro, HSOC, etc. After i got home, i just checked the current settings. Looked like the only changes were my default driving mode was set to COMFORT and door handle lights did not turn on when car is placed into REVERSE. Plugged in my OBDLink MX+ OBD2 & fired up Bimmercode, and re-set MY preferences.

Curious though, my HSOC menu (and possibly a few others) looked a bit different but the ability to select HSOC was not turned off. I guess the patch for that controls steering assist did not over write the rest of my settings.

Return to “Problems / Troubleshooting”