Philitup
Posts: 1
Joined: Wed Nov 25, 2020 7:59 am

Rex Problem!

Wed Nov 25, 2020 8:37 am

Hello, I wondered if someone could help ? I have a 2017 I3 with rex which doesn`t function correctly. When I switch to hold state of charge I get an error message stating (Only electric drive available , restricted range, Please go straight to the nearest BMW I service partner) I have tried this at 50% charge and 60 % charge and the rex will not come on even though it full of fuel. I have run the rex by opening the boot (Trunk) in emissions mode and it works fine. I also ran the car electric down to 5m range and the rex still did not cut in? Bit puzzling, I had heard that it may be a fuel pump relay but this would seem to contradict the fact that the rex works fine in emissions test mode? Any help would be much appreciated.

JohnKelly
Posts: 102
Joined: Sat Oct 07, 2017 7:02 am

Re: Rex Problem!

Wed Nov 25, 2020 10:04 am

If you do not have Hold State Of Charge enabled, it will not come on until your battery is at about 7%.. at least on my 2015. Perhaps the battery percentage it automatically comes on at is lower on the larger battery 2017? You should code HSOC and go from there. Miles remaining on the Guess-O-Meter is not an accurate way to judge remaining battery percentage. You can select to show battery percentage with the button on the end of the turn signal stalk.
2015 REX / Participating on plugshare w/level 2 Clipper Creek 32 amp, Moclips, Washington coast

Fisher99
Posts: 390
Joined: Sun May 12, 2019 6:24 pm

Re: Rex Problem!

Wed Nov 25, 2020 7:53 pm

I really don't have any idea, but please post here when you find out what is causing the problem. I don't think it's related to HSOC coding because you stated that the message says "..restricted range, Please go straight to the nearest BMW I service partner". If I try to activate HSOC above about 75% (I have coded my car to allow HSOC at 75% and below)) it just says that HSOC isn't available. Doesn't give the error message that you are seeing.
2014 BMW i3 with Range Extender Engine, Capparis White/Frozen Black, 20" wheels,, Giga World, Tech + Driving Assist, Parking Assist, DC Fast Charging, TurboCord EVSE

JohnWasser
Posts: 81
Joined: Sat Mar 07, 2020 6:15 pm

Re: Rex Problem!

Thu Nov 26, 2020 6:39 am

Does the "Check Engine / Malfunction Indicator" light come on? Have you checked with an OBD-II reader for trouble codes? They might provide useful detail.

Glennr
Posts: 3
Joined: Thu Mar 18, 2021 2:21 pm

Re: Rex Problem!

Thu Mar 18, 2021 2:35 pm

had similar problem turned out to be blown fuse for rex motor fan wont run motor without ability to cool radiator

Return to “Problems / Troubleshooting”