Page 1 of 1

Anyone else having issues with BMW connect App not working?

Posted: Fri Apr 02, 2021 9:37 am
by gps1539
When I try to start the BMW connect app on my android phone it fails with "Something went wrong, please try later". I've cleared the cache, deleted and re-installed the app but it still fails. Wondering if others are seeing the same issue.

Re: Anyone else having issues with BMW connect App not working?

Posted: Fri Apr 02, 2021 3:20 pm
by alohart
The "please try later" suggests that BMW's servers might not be working correctly when you launched the BMW Connected app. These servers are market-specific, so because the iOS version of BMW Connected works right now in the U.S. works for me, BMW Connected might not work for you if you're in a different market. But then, BMW's client-server implementation has never been very good, so it's difficult to determine what might be wrong.

Re: Anyone else having issues with BMW connect App not working?

Posted: Fri Apr 02, 2021 7:15 pm
by gps1539
Thanks Art, I'm in California and I'd guess we're connecting to the same servers so they maybe something phone related.

Re: Anyone else having issues with BMW connect App not working?

Posted: Sat Apr 03, 2021 9:50 am
by Fisher99
For what it's worth, the app is working for me on my Android phone. Art is located in Hawaii but I'm located in Oregon which may be the same market area as you, although I really don't know for sure. Sounds like it may be specific to your phone but you've already tried the obvious things so I'm not sure what else to suggest. Is there another Android phone in your family that you could try?

Re: Anyone else having issues with BMW connect App not working?

Posted: Sun Apr 04, 2021 9:37 pm
by gps1539
Thanks for letting me know it is working for you. I agree this sounds like an issue with my phone.

Re: Anyone else having issues with BMW connect App not working?

Posted: Thu Jun 10, 2021 2:27 pm
by Hoku
I'm in Hawaii also and the app doesn't work for me! I keep getting bad token message

Re: Anyone else having issues with BMW connect App not working?

Posted: Thu Jun 10, 2021 2:44 pm
by SSi3
Are you using the new My BMW app? The old BMW Connected app is done
https://www.press.bmwgroup.com/usa/arti ... my-bmw-app

Re: Anyone else having issues with BMW connect App not working?

Posted: Thu Jun 10, 2021 4:11 pm
by 3pete
FWIW, I just checked both BMW Connected and MyBMW apps and they were able to display the status of my car. I sent commands to the car via both apps and weirdly the BMW Connected one succeeded (allegedly) and the MyBMW app command failed twice with "Something went wrong, Retry?"

I'm in the midwest USA if that's relevant.

Re: Anyone else having issues with BMW connect App not working?

Posted: Thu Jun 10, 2021 7:16 pm
by alohart
Hoku wrote:
Thu Jun 10, 2021 2:27 pm
I'm in Hawaii also and the app doesn't work for me! I keep getting bad token message.
Using the My BMW app in Honolulu, I was just able to unlock the doors on the first try and lock them after 2 failures which seems to be fairly typical for me, so the app and the BMW remote server seem to be working about as well as they ever do.

A bad token message could be caused by some bad data stored on your phone. If you haven't done so, delete the app and its stored data, reinstall, and try again.