Dave
Posts: 2
Joined: Sun May 11, 2014 9:40 am

Chager Problems

Sun May 11, 2014 9:47 am

Hi All. The charging unit supplied with my i3 has packed up. When I switch it on I immediately get the charging fault red light flashing without even plugging it into the car. Amyone else had this? :(

Thanks

noakey
Posts: 398
Joined: Mon Jan 27, 2014 8:11 am
Location: Swindon UK

Re: Chager Problems

Sun May 11, 2014 9:56 am

Dave wrote:Hi All. The charging unit supplied with my i3 has packed up. When I switch it on I immediately get the charging fault red light flashing without even plugging it into the car. Amyone else had this? :(

Thanks
Hmmm didnt see the red lamp light up on the unit I used with a borrowed i3. I havnt tried the one that came with my i3 yet. Will try later.. time to wash her..again... :)
Neil

BEV at 21,000 miles in first 16 months.
Average 86 miles per charge.
Best on full charge 112miles, worst on full charge 55miles
Loving every mile :)

RJSATLBA
Posts: 292
Joined: Mon Jan 20, 2014 12:36 am
Location: Pool in Wharfedale, W Yorks, UK

Re: Chager Problems

Sun May 11, 2014 10:12 am

Hi,

Car not coming for ages but got the charger installed just in case the subsidy was withdrawn in the budget. Installer warned me that something similar might happen occasionally and, if so, to switch off the charger at master switch in the unit mounted below it, leave it for a short while and switch on again. Sounds like the automotive equivalent of 'close all the windows'!
Roger

i3 REx ordered 7 Feb 2014, delivered 8 Oct 2014

Stevei3
Posts: 365
Joined: Mon Sep 02, 2013 9:02 am
Location: the Netherlands

Re: Chager Problems

Sun May 11, 2014 11:51 am

Dave wrote:Hi All. The charging unit supplied with my i3 has packed up. When I switch it on I immediately get the charging fault red light flashing without even plugging it into the car. Amyone else had this? :(
Hi Dave,

yes, mine did get too wet at one time. It started flashing red like yours. I dried it for a good 2-3 hours on the radiator @home and all was well again.
Has yours gotten wet/damp ?

Regards, Steven

yaute
Posts: 6
Joined: Sun Mar 02, 2014 4:28 am

Re: Chager Problems

Thu May 15, 2014 8:11 am

Hi,

I'm facing the same problem on an I3/REX since end of April. By the way I've notice that battery life is going down slowly but surely (from more than 140km to less than 120km now). I keep you informed as soon as I've more information.

Image Image

BoMW
Posts: 265
Joined: Sun Feb 02, 2014 5:22 pm
Location: Sherwood Forest

Re: Chager Problems

Thu May 15, 2014 5:07 pm

I've had the above warning on ecotricity outlets, 4 in total. My socket flashes red and the screen says to little power from charging unit. I will ring ecotricity because so far I've had only one of their chargers work, out of 7.
My i3, collected 02/05/14---44000 miles by 30/05/16
SOLD 05/03/17 :(

Bunter
Posts: 372
Joined: Sun Nov 17, 2013 3:41 pm
Location: South Central England

Re: Chager Problems

Thu May 15, 2014 11:46 pm

BoMW wrote:I've had the above warning on ecotricity outlets, 4 in total. My socket flashes red and the screen says to little power from charging unit. I will ring ecotricity because so far I've had only one of their chargers work, out of 7.
Which sort of charger were they?

Bill
Born Electric 15.03.14

smharvey
Posts: 5
Joined: Mon Jun 02, 2014 11:12 pm

Re: Chager Problems

Thu Jun 05, 2014 11:46 pm

The day I brought my i3 home I got the message insufficient grid power using the supplied delphi 120V charger for US. The setting was to use the highest power for L1. The lights on the charge (Power Fault and Charging Fault) both blinked red. I tried low setting but nothing. Brought it to dealer, swapped chargers with new one. It started to charge and then stopped. The technician went into the software, cleared faults and deleted the factory or production mode. Tried again, started to charge then stopped. He then did it one more time and this time it worked. Car has been charging fine every day since. I now have the charge power for L1 set to low.

Hope this is helpful. If you get this, have them try the above before replacing hardware on your car.

Sean

CompuMagic
Posts: 66
Joined: Sun Feb 23, 2014 6:27 pm

Re: Chager Problems

Fri Jun 06, 2014 12:42 am

yaute wrote:Hi,

I'm facing the same problem on an I3/REX since end of April. By the way I've notice that battery life is going down slowly but surely (from more than 140km to less than 120km now). I keep you informed as soon as I've more information.

Image Image
Have you driven it with the gas generator on much and if so did you wait till the car kicked on the generator automatically or did you manually turn it on while the battery had a good amount of charge?

yaute
Posts: 6
Joined: Sun Mar 02, 2014 4:28 am

Re: Chager Problems

Fri Jun 06, 2014 1:01 am

CompuMagic wrote: Have you driven it with the gas generator on much and if so did you wait till the car kicked on the generator automatically or did you manually turn it on while the battery had a good amount of charge?
The problem is not related to the gas generator. In any case BMW will inspect my car on next Tuesday. I'll keep you informed.
FYI, the car has 7000km, I did only one test of more than 240km on the highway with the gas generator forced. Since this test, the gas generator in on automatic mode and I've filled back the tank.

Return to “Problems / Troubleshooting”