dddoughboy
Posts: 6
Joined: Sat Nov 13, 2021 9:04 pm

"Insufficient Grid Power" error at beginning of charging

Sun Jan 09, 2022 1:02 pm

Our 2014 BEV is starting to give problems. The most troubling one is an intermittent (though starting to occur more often) error when we begin to charge. The LED's around the car's charge port will start flashing red and the screen inside will say Insufficient Grid Power and then no charging occurs. This is when using a Level 2 charger in our garage (220/240v). We've had this car for 3 years and never any issues, so not sure why this would be happening now. Recently, when this occured, I drove the car to my neighbor's house and tried his Level 2 charger and got the same error. So that likely rules out the charger being a problem.

When this occurs, if I switch over to the stock BMW Level 1 charger on a standard 110v house plug, that works fine, and get no error.

It sounds like it might be a problem with the BMS in the car? If so, curious if this is still covered under warranty as being part of the battery system which has the 8 year/80,000 mile warranty? I'm in California and it is the BEV, so my understanding is that the warranty isn't quite as generous as the REX models.

Any help would be appreciated. Thanks.

alohart
Posts: 2488
Joined: Sat Nov 01, 2014 7:36 pm
Location: Honolulu, HI

Re: "Insufficient Grid Power" error at beginning of charging

Sun Jan 09, 2022 8:46 pm

Please don't post about the same problem in more than one forum: viewtopic.php?f=15&t=17613#p70568
Aloha,
Art

2014 BMW i3 Arravani Grey, Giga World, Tech + Driving Assist, Parking Assist, DC Fast Charging, JuiceBox EVSE

Return to “General / Main i3 Owners Forum”