glim1000
Posts: 7
Joined: Sun Dec 15, 2019 4:10 pm

Washer fluid pump noise but no spray on front or back window.

Sun Dec 15, 2019 4:58 pm

I'm new to i3, I have a 330i and an X5 and do all my own mechanical work so am familiar with the normal parts of BMW. I am testing the electric waters for the first time with a second hand 2014 i3 Rex. The i3 washer pump location is so easy compared to a 3 series or X - it takes about 10 minutes to sort this out.

Document with Pictures: https://docs.google.com/document/d/1QnF ... sp=sharing

The i3 uses the same pump style as all their other cars and the filter can clog over time. If you hear the pump buzzing but no washer fluid is coming out then the filter is clogged. If you no longer hear the pump buzzing then it is the pump. I would check the filter first before ordering a replacement pump. You will only need a T-25 bit to sort out this issue:

1. Open the Frunk
2. Using a T-25, remove the six screws holding down the storage box in the frunk:


3. remove the covers to each side of the storage box, they are held in place by velcro

4. remove the storage box

5. To the left of the storage box, you will see the washer pump, it is held in place by the slot in the side of the washer reservoir. Remove the top electrical connection, then the clip holding each side of the water tubes to the bottom of the pump:

6. Pull or pry the pump away from the reservoir and lift up, the pump has a tube in the bottom that connects to the rubber filter in the reservoir.

7. Remove the rubber filter that the pump was seated in and check that it does not have slime or debris in or on the filter. I could not take a picture of this as I had my finger in the filter hole. Mine was clogged with slime and debris.

8. Let some fluid drain out of the reservoir to clear any slime from the bottom of the washer reservoir and then use a rubber stopper or rubber glove to plug the hole.

8. Clean the filter and replace

9. Reseat the pump, put the hoses back on, push the clips down to lock them in place, and the electrical connection, and test the washers.

frictioncircle
Posts: 94
Joined: Fri Nov 25, 2016 11:23 pm
Location: USA West Coast

Re: Washer fluid pump noise but no spray on front or back window.

Sun Dec 15, 2019 11:22 pm

Very nice writeup, thank you for sharing! Hopefully those pics will stay available for a long time.

Elsewhere I've been referencing a forum post about an ICE BMW's washer motor. The post is only from 2017 but the photos have already gone offline. :evil:

KarlC
Posts: 44
Joined: Wed Nov 27, 2019 1:15 pm
Location: San Diego Ca

Re: Washer fluid pump noise but no spray on front or back window.

Mon Dec 16, 2019 8:20 am

Great post, Im sure it will be very helpful to others !

Thx Karl
2015 i3 Rex, Arravani Grey, Tera World, Technology, Driving & Parking Assistant, Harman Kardon Audio System, 19" wheels

alohart
Posts: 1989
Joined: Sat Nov 01, 2014 7:36 pm
Location: Honolulu, HI

Re: Washer fluid pump noise but no spray on front or back window.

Mon Dec 16, 2019 11:53 am

frictioncircle wrote:
Sun Dec 15, 2019 11:22 pm
Hopefully those pics will stay available for a long time.

Elsewhere I've been referencing a forum post about an ICE BMW's washer motor. The post is only from 2017 but the photos have already gone offline. :evil:
Because of this, I downloaded the referenced report and have saved it with my other i3 articles.
Aloha,
Art

2014 BMW i3 Arravani Grey, Giga World, Tech + Driving Assist, Parking Assist, DC Fast Charging, JuiceBox EVSE

youngwilliam
Posts: 4
Joined: Sat Jun 01, 2019 8:53 am
Location: San Francisco, CA

Re: Washer fluid pump noise but no spray on front or back window.

Mon Dec 16, 2019 7:11 pm

I'm part Luddite, so I simply printed the document and filed it with my other manila-colored file folders. Thanks for sharing.
2018 i3 BEV
2006 530i
1987 528e (Retired)
1976 2002

Heida
Posts: 1
Joined: Thu Mar 19, 2020 5:05 pm

Re: Washer fluid pump noise but no spray on front or back window.

Sun Mar 22, 2020 12:09 pm

Excellent writeup by Glim1000.Thank you. I followed the precise instructions to remove the unit and discovered a small crack in the plastic at the aft high pressure line feeding the windshield. The crack-leak was on the bottom and impossible to see unless the pump is removed. I purchased another unit at AUTO VALUE for CDN$50 in Canada. This is link to the unit for USA ( https://myautovaluestore.com/trico/wash ... tri-11-613 ) Pump unit is almost identical except the distribution (shuttle valve?) cylinder where the two high pressure lines attach on opposite sides is reversed. There is no difference in operation. Operational and leak checks performed and all OK.

Return to “Problems / Troubleshooting”