BMW Connected App doesn't even show range!

BMW i3 Forum

Help Support BMW i3 Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Well-known member
Mar 4, 2018
Hoping someone might be able to help. I cannot view even the range of the car.

The BMW Connected app shows everything in the Remote Section like normal except the entire line showing range for both the REX and Electricity is completely gone. I had lost the ability to use Climate Control, but realized it's b/c my subscription was expired. I renewed it and can now do the remote functions but my range info is still gone. Sorta important. Wondering if anyone has had this issue and can suggest a fix.

Screen looks like

Things I've already tried:
1. Uninstalled the app. Reinstalled.
2. Disconnected phone from the car and reconnected it.
3. Updated the Connected Assistance by plugging the phone into the USB under the arm rest.
4. Connected via USB under the armrest as the Connected app says to do to let the car "read" the range.
5. Banged my head into the steering wheel out of frustration.

Still no range info on my app. Anything else I should try?
Don't know if this will resolve your problem, but it's easy, so worth trying. Try pulling fuse #115 (located in the fuse panel under the glove box). Wait a minute or two, then plug it back in. This resets the cellular connection.
Sipabit- Had the same thing happen to me on my 2015 CPO REx. Initially took to BMW (wish I was here first), they did a bunch of diagnostics, “refreshed the modules software” and it worked again. Apparently software updates are NOT covered under CPO, so guess who paid $650 bill. Yup, fun times.

Fast forward 60 days, same behavior- app won’t update mileage, location, send/receive commands. Pulled the fuse, has worked like a champ ever since.
Thank you both of you for taking time to respond! Much appreciated. Sounds easy enough. Just after reading your post and as I was on my way heading downstairs to the garage, I checked my phone one last time after having checked it a zillion times before over the course of the past several months but oh and behold, the mileage showed up!

Why? I think it may be that my phone wasn't up to date on the latest IOS. It was only released a day or so ago but I did update it before just a moment before I read your posts and my guess is that it's the latest IOS update that made it work again.

I'll definitely try that trick with the fuse though. I used to have to do that when my radio stopped working on my last car. Was a pain to have to do so often, but was easy enough.

@BL5, sorry to hear about your $650 bill and having the problem repeat itself! I run a dash cam on my car and forgot to turn it off when I left my car at the dealer to do an inspection of my wheels not being even on both sides. It recorded the whole thing. The kids (literally 20 something) had the car up on the lift for less than 5 minutes. The other 10 minutes he and his colleagues were just spending laughing at my car's side mirrors and the fact that I was complaining that one side was sticking out further than the other (which to this day is still the case but apparently I'm in decent company as others at least on other cars have reported the same, quality issue I think).