I3 REX 2015 125001,125002,125003 Misfire

BMW i3 Forum

Help Support BMW i3 Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Dec 10, 2022
I thought I should share my experience with this problem so far.
I got the drivetrain error message come up on the highway, did not get any other warnings before.

I am following the ISTA test plan for the error.

Here is what I have done so far.
1- Replaced Fuel Pump Relay
2- Spark Plugs
3- Tested coils for spark.
4- Checked Fuel Pressure (75 PSI) (No sensor or port on car for this, you need external pressure gauge a bit of a mess)
5- Tested fuel injectors by applying 12V each (this may not be a conclusive test)
6- Tested MAP sensor for both pressure and temperature
7- Smoke test to see if any leaks
8- Next in line is to replace the crankshaft sensor per ISTA

Currently, when I try to start the engine using emission start procedure, it starts ok and keeps the RPM at 2100RPM for total of 20 seconds and quits throwing the error codes at the real engine start which is after the 5-10 seconds. Since it is a distinct and quick error, I tend to believe it might be a sensor like crankshaft sensor that responds quickly.
The starter runs for a very long time in these engines unlike a regular engine start.
The oxygen sensor AIR/FUEL ratio goes up to 1.99 (MAX), telling me that it is super lean condition.
I monitor these using the ECU functions for RDME in ISTA.

The fuel pump relay is a likely candidate, but as you’ve replaced it, along with the spark plugs, I’d take a closer look at Lambda oxygen sensor. Had similar issue with mine and BMW will literally replacing parts left, right and centre. They changed out this sensor and even the fuel tank first. Then finally the fuel pump relay.

Part for mine was 11788604930

I should say it wasn’t a misfire, rather CEL error, to the point the engine wouldn’t engage. It would also be worth investigating the HV cable points. These cars do suffer from corrosion and moisture on these points. Switch off under the frunk before releasing, cleaning and reattaching cable points.
I just did the compression test, they are 241 and 242 PSI.
Also, I attached injection test bulbs on the outputs, it only lights up for 2 seconds and quits while the engine is still cranking.
It seems to just not like something before engine has a chance to start up.
Hi spartacus68-
That number is for after cat oxygen sensor. I did not check that one yet. Do you think your problem was solved with this sensor in the end?
I just tested the after cat oxygen sensor using ISTA, RDME diagnosis page. It always reads 1.28V. It is a four wire sensor so it is probably not wideband, so it may need to completely heat up before reading anything good.
It would be really nice to have a good working RDME test values on this forums so we know what we should expect for a normal operation.
I will surely post them once I can run mine.
I disconnected the connector to the throttle body and tried to start the engine. And it started and kept running without stopping this time. The AFR went down to around 1 instead of 1.99. It sounds a little rough but not too bad, expected. When I manually close the throttle a little it actually sounds normal and pressure reading gets in the range, 57Kpa.
It may be the throttle body ?
Also, I only have the throttle body communication errors and no misfire errors.

I can probably say what it is not,
1- Injectors
2- Oxygen sensors
3- Coils
4- Spark Plugs
5- Fuel Tank related issues
6- Camshaft Sensor
7- Crankshaft Sensor

It still can be
1- Vacuum leak
2- Clogged intake return lines, (turbulence lines)
3- Throttle body
There was a discussion about this TSB on facebook group today:


Not sure if it is useful for your car. The solution costs $16, so worth trying.

Some claim this is the same as Techron fuel additive that you can buy for $8.

My understanding is that engine control module cannot compensate for garbage winter fuel and altitude.

P.S. I see online part stores offer the BMW part for around $9, so that would be my choice:

rickcvk said:
Hi spartacus68-
That number is for after cat oxygen sensor. I did not check that one yet. Do you think your problem was solved with this sensor in the end?

Apologies for delay in responding. They swapped it out, but it was the fuel pump relay that eventually sorted it. Just to reiterate, it wasn’t a misfire, but engine refusing to fire up.