Unreliable REX Won't Start - What fixed yours?

BMW i3 Forum

Help Support BMW i3 Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Sep 14, 2019
I have had an 2014 i3 Rex for about 5 months. I have seen inconsistencies with the REX as far as when it works and when it doesn't. In all of my research it seems to be potential for a lot of things, but I'd like to gather some sort of consensus as to how people fixed theirs. Mine is currently at the dealer, and they are just beginning to troubleshoot. My REX got to the point where it would never start and CEL was on, but went off the next day, but the REX still does not start, so I thought it was time for the dealer, as I had recalls to go in for anyway. Unfortunately, I am not getting "warm fuzzies" from the dealer, as they have told me that it has a code for O2 sensor and needs an oil change. These things don't seem to be things that would prevent it from starting at all. And since this is the US version of the car, by default they were coded to have the REX engage at very low battery, so I am not even sure how often they have seen this problem. I cannot imagine not having hold state of charge, and just hoping the REX comes on with the battery is at 5% or whatever it is set to by default, especially now that I see how unreliable mine has been.

My Car:
2014, REX, Terra
84,000 miles
US Version, Coded for Hold State of Charge being allowed at 75% battery

My Symptoms:
Early - Randomly (about 20% of the time) when I wanted to engage the REX, It would show the Drivetrain Error, But continued driving was possible, seek dealer assistance. NO Cel light. I would wait, try again, and it would work.

Recently - Now 100% of the time the REX does not want to turn on. When trying several times with in a short time frame, the CEL comes on. The code was a generic P0004 it threw. Next day, CEL light is out.

I've Checked/Tried:
Voltage on 12 V battery. As others have discussed, getting a true resting reading on this can be a challenge. When the DC/DC converter is on, its a constant 14.07 volts to the battery. I had the voltmeter directly on the terminals, but this mean the frunk was open, so I don't know if this keeps the DC/DC converter on all the time. I saw the voltage change as I left the car alone, but it never got down to 12.6 volts which is where a good 12 v battery would be at rest. Even after hours of leaving it alone. It did not matter if it was charging or not. I had the dealer check the battery, they tell me its fine. As far as I can tell the battery is original, but I cannot confirm that.

Trying to start the REX manually for emissions testing per: https://www.youtube.com/watch?v=gsUOvjzGbjU . The resulted in an error message saying "Emissions test not currently possible". So manual start would never work.

Potential things I have read about that can be the fix:
1. Software/Firmware update. I ask the dealer about this, and there is no response. Are there actual Recalls specific to the REX? Dealer did not find any on my VIN.
2. Gas tank pressure sensor.
3. Filling the gas tank too high.
4. Fuel Pump Relay https://www.mybmwi3.com/forum/viewtopic.php?f=13&t=4527&start=10 (this one seems to have many positive responses)
5. Replacing many parts on the REX as outlined in others responses. Fuel Pump,Injectors/Gaskets/etc.
6. 12 Volt battery. Does the REX start off the 12 volt battery, or the high voltage pack? I cannot seem to find an answer to that.

I am clearly out of warranty at this point, and they've asked for 140$ to just start troubleshooting. But when asking them about seeing these issues, they do not seem to have a response, and it seems like they would be starting the troubleshooting path from scratch, and I am afraid of the costs that could be related to this. Reading about this issue online it seems to be very prevalent. And as the older i3 Rex's come off warranty, more and more people may need answers to this hence my post. Not optimal, but on the table is just throwing out the REX all together depending on the costs to fix, if that is even possible.

Of course its possible that mine is a one off with its own issue, so I will also be posting the results of what the dealer did to fix if they fix it. I am going to be reluctant just let them start poking in the dark as to issues with it. As you can see I do not have much faith in the dealer.

Sorry for the long read, just hoping that we can gather information and have this post help others with their Rex's.
The only thing the 12vdc battery does is run computers, accessories (seat heaters, rear window defrost, fan,etc and lights)...IOW, no, the REx never 'sees' the 12vdc battery for cranking power, but it does control the computer that performs that function.
Thanks for that info - it makes sense that the tiny 12 volt battery would not be responsible for starting the REX.

I have been told by the dealer that it is the fuel pump relay causing my REX not to start. For the sake of information sharing, someone created a video on how to replace it. https://www.youtube.com/watch?v=KkF5VvmlZCM. My REX also exhibited the same behavior in it would start for a second and stop, and that is when the CEL came on. It only did that once though while I was trying to put it in emissions check mode.

I wish I would have tried this myself now. Should have taken the other posts about this more seriously, but I could swear I heard the fuel pump running. Will follow up confirming that this is what it was.
FWIW, you can't start the emissions test unless your battery level is below 75% I think you'll find...once running, it needs to run for awhile, and it needs someplace for that generated energy to go.
enzeno –

Seems you're making progress on your issue. Regarding the 12V AUX battery voltage, I also saw 14+ volts when the the car was partially powered-up.

With the hood up, I locked the car from the keyfob. In this state I measured about 12.6V.
Thanks for the info about the testing the battery condition. I did not even think about locking the car to see if that would disable the DC to DC converter, which it sounds like it does.

Yes, I did know about the 75% thing for the emissions test, if you try to start it above 75% it tells you the battery level is too high. Oddly though, I received this message even at 50%, but I think I had done one or two steps out of order when trying, as when I got my car back yesterday I was able to successfully enter emissions mode.
So I got my car back repaired and everything works as it should. Now disappointingly, they also seem to have updated software on the car, so it may be possible that this had something to do with getting the REX fixed. I know this because all of my coding was gone when I got the car back. So if you go to the dealer for this issue it may be worth telling them the car is coded. They should have been able to backup and restore all the settings. I mean I am glad the software is updated, but I was looking for a concrete answer to this issue. I believe it was most likely the fuel pump relay. Its a 20$-ish part if you DIY. I will just say its a LOT more expensive at the dealer.

From my research, it also seems that the fuel relay can go bad multiple times. Some people have reported even keeping spares with them. So if this starts again I will update the thread.
FWIW, whenever the dealer does a s/w update, it restores EVERYTHING to the default for your market area. It's also possible that without updated s/w on your part, that you won't be able to then retweak things until you get updated data files. IOW, they don't and won't save anything you may have changed and then restore it.

Another thing that sort of bugs me is that, unlike years ago when they listed areas changed in s/w updates, now, they don't even tell the dealers. They only look to see if your symptom was addressed to decide if it is a known s/w issue, but that new build might have numerous other (usually small, but you won't know) changes as well.
I sincerely hope your issue is not the same as mine. Same year and model. Same error code and symptoms. It is at the dealer now and they need it for a "week or so" They say the whole Range Extender motor needs to be replaced! 58000 miles. This is quite disturbing to me for obvious reasons. The only saving grace for me is we have the extended warranty protection from BMW and they are doing the work under the contract for free and they have given us a loaner. Best of luck to you.
A simple 20$ relay fixed mine, so they tell me. I mean its working for now, but they did other things as well. I sure hope they at least tried that for you, but I guess if they can bill a warranty to replace the whole thing they might just do that too I guess. They asked me when I got there if I had any extended warranty, which I do not.
The best technical info I have found is here


I hope i dont have to use it